프로그래밍 QnA + 설치 및 활용 QnA

dgsquare의 이미지

gcc에서 naked 선언자를 사용할 수 있나여?

_declspec(naked) void func()
{
....
}

이런 구문이 있는데요.
naked를 적어주면, 컴파일할때, ebp 및 esp를 할당 및 해체헤주는 코드를 삽입하지 않는다고 알고 있습니다. ( inline asm에서 자주 쓰일것 같군요.)
근데 검색을 해보니 VC계열에서만 사용하는 것 같은데, gcc에서는 비슷한 기능을 구현해주는 선언자가 있는지 알고 싶습니다.
그리고, _declspec도 VC에서 사용하는 선언자 인가요?
읽어주셔서 감사합니다^^-
박민권의 이미지

안전한 x윈도우 사용

리눅스를 안전하게 사용하려면 필요할때를 제외하고는 root 계정을 쓰지 않고 다른 계정을 써야 한다고 알고 있습니다.

그런데 root가 아닌 다른 계정으로 쓰려니 불편한 점들이 많은 것 같습니다.
리눅스를 데탑으로 쓰려고 하다보니 프로그램 설치하거나 지울때마다 root로 들어가야 하고 마운트한 폴더에 파일을 쓰려고 하니 권한이 없는등 번거로왔습니다.

root 대신 사용할 계정에 대해서 뭔가 특별한 권한을 주고 셋팅해야 하는건지 아니면 보안을 위해 불편함을 감수해야 하는것인지 잘 모르겠습니다.

dordory의 이미지

plugin에서 system() 함수를 사용할 수 있나요?

리눅스의 plugin(.so)에 대한 질문입니다.

plugin에서 코멘드 명령어를 실행 시키는것이 가능한가요???
제 생각에는 안될것 같은데...

예를 들면 이런 경우 입니다.

sprintf(CommandBuf, "/usr/bin/htpasswd -mbc %s %s %s",
WEBPASSFILE, pUserID, pUserPass);
system(CommandBuf);

위와 같은 코드가 plugin 안에 있어도 실행이 되나요?
문제는 쉘에 이 명령 코멘드를 전달할 수 있냐있데...
만약에 안된다면 대안으로 어떤 방법을 생각할 수 있는지좀 알려 주시겠습니까?

제가 plugin 개발 경험이 없어서 잘 모르겠네요...

assa의 이미지

[STL]메모리 해제에 관해서..

STL을 사용하면 동적으로 메모리를 할당하지 않은 이상,

굳이 메모리해제를 임의적으로 할 필요는 없다고 하는데요.

메모리 해제를 꼭 임의적으로 해야만 하는 경우는 어떻게 하나요?

예로

vector< int > tvector;

for(){
    tvector에 자료를 집어 넣음
}

// 작업도중 tvector에 할당된 메모리를 삭제하고 싶다.
tvector.~vector<int>(); // 에러

할당된 메모리를 강제로 제거하려면 어떻게 하나요?

facered79의 이미지

linux 환경에서 udp 소켓통신을 하는데요..

pf 와 af 를 서버와 클라이언트 둘다

pf는 PF_LOCAL
af는 AF_LOCAL

로 사용했습니다.

INET 로 할때는 잘 되던 통신이

LOCAL로 바뀌니까 SEND에서 -1을 리턴 합니다..

원래 안되는 것인가요??

sazaang의 이미지

시리얼 통신 프로그래밍 완전초보가 정말 궁금합니다.

이번에 c문법공부를 하고나서 vc를 이용해서 모뎀으로 서로 채팅하는 프로그램을 한번 구현해볼려고 하는데요. 찾아보면 vc로는 전부 mfc로 구현하드라고요, 근데 저는 그냥 open 이랑 write같은 함수들을 써서 해야되는데요, 묻다보니까 여기까지 오게됐습니다.
어떻게 시작해야되는지 open, write등은 어떻게 쓰는건지 자세히 좀 알려주시면 감사하겠습니다.

espoirgod의 이미지

하나의 디스크에 2개 이상의 리눅스 설치에 대해서~~

파티션은 다음과 같이 나눠집니다.

hda1 - 와우리눅스 설치해서 사용중
hda2 - swap
hda3 - 확장파티션
hda4 - 윈도우 설치
hda5 - Fedora Core 4 설치
hda6 - 아직 사용하지는 않지만 다른 리눅스를 설치할 것임

hda5 에 Fedora 를 설치했습니다.
Boot Loader 는 hda1 에 설치된 lilo 를 사용하려고
설치하지 않았구요.

hda1 의 /etc/lilo.conf 에 다음의 내용을 추가하고
lilo 를 실행함으로써 설정 내용을 적용했습니다.

label=hda5
root=/dev/hda5
read-only
kernel=/boot/vmlinuz-xxxxx

kernel 이름은 hda5 의 /boot 아래에 있는

ulra의 이미지

ElectricFence 를 어디서 구할 수 있나요?

ElectricFence 를 어디서 구할 수 있나요?
웹문서에서 찾아봐도 원 제작사 홈페이지를 못찾겠습니다.
물론 제가 검색이 꽝이라서.. ㅡㅡ;; 그럴지도 모르겠네요.
redhat linux 7.2에서 운용이 가능한 최신버전을 구합니다.
부탁드립니다.

daggy0927의 이미지

RTP 관련 도서 추천 해주세요

전반적인 RTP관련 사항과 VIDEO, AUDIO와 관련된 특징 등에 관해 알고자 합니다.
RTP와 관련해서 직접 구현할 것은 아니구요
업무상 Follow up할 일이 있는데 RFC관련 스펙은 너무 보기 힘드네요.
제가 알고자 하는 부분은
RFC 3550 중 RTCP를 제외한 RTP 부분
RFC 3984, RFC3640 입니다.
원서보단 한글로 된 책 추천해주시면 감사하겠습니다.^^

shilf의 이미지

가상 경로 관련해서 질문 드립니다.

다음 대용량 파일 전송에 보면
전송후 보여주는 경로가 실제 경로가 아닌
가상 경로인것 같습니다.

단순히
www.test.co.kr/abce.abc
를 어떻게 암호화해서 올린다고해도
www.test.co.kr/abce.5sklef8ik%d%dfj.dhabc
뭐 이런식으로 바뀐다고 이게 가상 경로가 아니지 않습니까?

실제 보여주는 주소랑
연결되는 주소가 다른것이 가상 경로 아닙니까

그럼 가상 경로를 만들려면
웹서버에서 id?=1dkkf 뭐 이런 php로 해서
처리하는겁니까?
다음 주소는 그런식으로 안나오던데요.

페이지

프로그래밍 QnA + 설치 및 활용 QnA 구독하기