질문

focus의 이미지

logrotate에 관련된 질문입니다.

/var/log/messages 파일에 다음과 같은 내용이 있어 문의드립니다.

logrotate : ALERT exited abnormally with [1]

위 로그가 3줄 정도 더 있습니다.

구글에서 찾아 보았지만 무엇이 문제인지 판단이 안되어
이렇게 질문을 올립니다.

OS는 Fedora core 2입니다.

lovethecorners의 이미지

Ubuntu 5.10 에서 Apache2 다시 설치 질문입니다.

apache2를 사용중이었습니다. 우분투에서 /etc/apache 폴더를 지운다는 것이 /etc/apache2 폴더를 지웠습니다....OTL apt-get remove apache2 한후에 다시 설치를 해도 더이상 /etc/apache2 폴더생성이 않됩니다. apache 1.3.X 의 버전도 /etc/apache 폴더 생성이 안되고...휴 어떻게 해야 될까요....

우주의 이미지

디바이스가 close가 안됩니다...???

어플리케이션 초기화 부분에서 아래와 같이 system펑션으로 neta.exe를 실행시켜 놓습니다.
system("/neta.exe &");

그리고 필요에 의해 비디오 디바이스를 close시키는데 디바이스 드라이버로 close가 전달이 안됩니다.

그래서 원인을 살펴보던 중 neta.exe를 실행시키지 않고 디바이스를 close해보니 그때는 close가 잘 됩니다.

이런 경우가 발생하는 이유나 해결책을 아시는 분 계신가요?
도움을 부탁드립니다.

등짝을보자의 이미지

aMule에서 검색한결과와 Pruna에서 검색한결과가 왜 틀린가요??

동키서버1,2

을 쓰는데요...

프루나에서 검색한것과

aMule2.0.0 에서 검색한것이 결과가 틀리더군요...

어뮬에서의 검색이 굉장히 좀 약해요...:(

예을들어 "베르세르크 270" 을 푸르나에서 검색하면 나옵니다...

하지만 어뮬에서는 이렇게치면 안나와요...

"베르세르크"이렇게 쳐도 나올까말까 하더라구요..

왜이런 차이가 보이는거죠?? :|

sw0rdfish의 이미지

vim 에서 여러파일을 동시에 검색할순 없나요?

vim에서 파일을 열고 어떤함수 이름을 검색하는데

하위 디록토리에있는 모든 파일에서 검색하고 결과를 나타낼순 없나요?

wafe의 이미지

안전하게 this의 shared_ptr 얻는 방법?

class MyClass
{
public:
  void AddToList(MyClassList &list)
  {
    // 바로 이부분!
    list.push_back(this);
  }
};

typedef boost::shared_ptr<MyClass> MyClassPtr;
typedef std::list<MyClassPtr> MyClassList;

...

MyClassList newList;
MyClassPtr newInst(new MyClass());
newInst->AddToList(newList);

이런 코드가 있을 때 표시해 놓은 부분의 코드를 어떻게 써야할 지 모르겠습니다.

list.push_back(MyClassPtr(this));

라고 쓰면 문법적으로는 맞지만 인스턴스 하나를 가지고 shared_ptr 두 개를 만들게 되어 문제가 생기죠.
icemaker의 이미지

도와주세요. 아파치 실행시 에러가 납니다.

# ./apachectl restart
httpd not running, trying to start

실행시켜 보면, 데몬은 뜨지 않습니다.

로그를 보면.. 아래와 같은데요. 도와주세요..

몇번 재설치해봤는데요.

===================================
에러내용

# tail error_log
Syntax error on line 233 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/mod_access.so into server: dlopen: /usr/l
ocal/apache2/modules/libphp4.so: symbol "_pcre_default_tables" unresolved

233줄은 아래 내용입니다.
LoadModule access_module modules/mod_access.so

sosiq의 이미지

프락시 서버 데몬 실행 오류입니다.

프락시 서버를 처음 해보려고 하는데요.
책을 봐도 모르겠고 해서 글을 올립니다.
데몬 실행중 아래와 같이 오류 메세지가 출력 되는데

$SQUID $SQUID_OPTS 2> /dev/null

conf파일에서 이 부분을 찾긴 찾았습니다.
어떤 식으로 수정해야 데몬이 실행될까요?
그리고 프락시 서버가 구동되는 순서좀 적어주세요;
개념 이해 부터가 안되니 공부하기가 힘드네요;

orionkhw의 이미지

'NFS mountd를 종료중입니다'

다시 또 올리게 되서 죄송합니다. 그동안 이것저것 해봤는데 영 답을 못찾아서 이렇게 다시 올립니다.

본론으로 들어가서 일단 현상이 아래와 같습니다.

[root@mycom ~]# /etc/init.d/nfs status
NFS mountd를 종료 중입니다: rpc.mountd (pid 2723) 가 실행하고 있습니다..
nfsd (pid 2718 2717 2716 2715 2714 2713 2712 2711) 가 실행하고 있습니다..
rpc.rquotad (pid 2709) 가 실행하고 있습니다..
[root@mycom ~]# /etc/init.d/nfs stop
NFS mountd를 종료 중입니다: [ 확인 ]
NFS 데몬을 종료 중입니다: [ 확인 ]

preppiepjh의 이미지

특정포트로 연결이 안되는 경우, 방화벽에 의한 것인지. 서버 문제인지. 확인방법이 있을까요?

안녕하세요?^^

제가 이번에 서버를 구축하면서..
유동아이피 환경에서는 80포트에 HTTP데몬이 떠있음에도 불구하고
80포트가 막혀있을 수 있다는 것을 알았습니다. ㅡ.,ㅡ;;

그것도 모르고 몇일을 고생했었어요~;;

혹시

해당 포트가 방화벽에 의해 막혀있는 경우인지, 아니면, 해당포트를 사용하는 서버 자체가 없어서 연결이 안되는 것인지 구별할 수 있는 방법이 있을까요??

페이지

질문 구독하기