프로그래밍 QnA + 설치 및 활용 QnA

aprilblue의 이미지

pipe에 관해서 궁금한게 있는데요

명명되지않은 pipe()는 하나의 프로세스에서 fork에 의해 생성된 프로세스들과만 통신할 수 있잖아요

그런데 다중 모듈 프로그램으로 fork를 써서 pipe로 통신하려고하면 할 수 없나요? 제가 프로그램을 짰는데, write로 보내는데까지는 되는데 read에서 block이 되어버리네요

구조는
main.c에서 fork와 pipe를 실행하고
자식 프로세스인
child1.c와 child2.c, child3.c 셋이서 통신하려고 했습니다.

다중 모듈 프로그램에서는 pipe통신이 안되는건가요?제가 프로그램을 봤을 때는 그것밖에 생각되어지지않아서요..

yipc의 이미지

higate plus 모뎀을 이용한 napt 기능에 관하여

kt 메가패스 외장형 모뎀중에
higate plus 제품에 대하여 여러분의 의견이 듣고싶어요

- ANSI, G.DMT, G.Lite Modulation지원
- RFC 2364 PPPoA, RFC 2516 PPPoE, RFC 1483/2684 bridged and routed mode, RFC 1577 Classical IP and ARP over ATM 지원
- DHCP, NAT/NAPT, IGMP proxy 지원
- IP routing 기능

이제품은 위에 기능을 지원한답니다.

그렇다면 굳이 공유기 사용해서 여러대 컴퓨터 이용할 필요있을까요?

개인 사용자가 서버를 운영하고자 할때(아이피 공유기 없는상황)
인터넷 바로연결컴(xp), 두번째 컴(리눅스)

jjkyj의 이미지

배열로 구성된 2진수를 10진수로 바꾸는 법

[C언어로 512비트 이상의 큰 자리의 수를 나타내기 위해 배열을 사용했습니다.]

2진수가 배열로 구성되었을때 ( a[MAX] = "010001010...")

이것을 같은 형식으로 10진수로 나타낼 수 있는 좋은 방법이 없을까요?

10진수를 2진수로 바꾸는 건 일단 성공했는데[2로 계속 나누는 계산을 구현]
2진수에서 10진수로 바꾸는 건 어떻게 해야할지 방법이 잘 떠오르지 않네요.
2의 지수승으로 나타낼 수 있는 수의 범위도 한계가 있을테고..

coolig의 이미지

노트북 PCMCIA 무선랜 카드 설치 오류... 조언좀..ㅜㅜ

그동안 필요에 의한 부분만 리눅스 시스템을 이용하다가 조금 더 깊게 배우기 위해서 개인 노트북에 리눅스를 설치하고 있습니다. 근데 무선랜카드를 인식시키는데 어려움이 있어 이렇게 도움을 요청합니다. ㅜㅜ

버팔로 회사의 PCMCIA 방식을 이용하는 무선랜 카드입니다.

HaanSoft에서 배포하는 최신버전으로 설치를 했구여..

ifconfig에는 당근 인식 못해서 내장랜 eth0과 lo만 있구여.

pcmcia status 를 실행해 보면

[root@coolig ]# service pcmcia status
cardmgr (pid 2888) is running...

kknd345의 이미지

어셈블리어에서 데이터 세그먼트에서 LENGTHOF나 SIZE에 대해서

보통 데이터 세그먼트에

.data
NUMBER \
BYTE 20,30,40,50,60
BYTE 21,32,45,32,11
BYTE 45,32,11,32,11
BYTE 21,32,45,32,11
....... 더 있다고 가정하고요

이렇게 잡혀 있으면요.

SIZEOF나 LENGTHOF 해도 첫줄만 읽어서

즉 BYTE 20,30,40,50,60

이것만 읽어서 5란 숫자를 ax에 넣잖아요

그런데 제가 원하는건 아래에 있는것 까지 전부다 읽어서
길이나 size를 구하는 거거든요. 방법 없을까요?

dgsquare의 이미지

pipe가 비어있는지 확인하는 함수가 있나요?

pipe를 간단히 구현하고 있고요.
blocking/IO Mode로 사용하고 있습니다.
process간 전송은 pipe로 진행되고 있으며, 마지막 명령이 끝난 결과값을 화면으로 출력시켜주기 위하여, read하여 buffer로 보낸뒤 출력시킬려고 합니다.
근데, 어떤 명령들은 출력이 없습니다. 이렇게 출력이 없는상태에서 read가 일어나면 blocking되면서 누군가 pipe에 write할때까지 기다리는 것으로 알고 있습니다. 이런것을 처리하기 위해 read전에 pipe가 비어있는지 확인하고 싶은데 방법이 있나요?

nonots의 이미지

[질문] 아파치 KeepAlive 를 off 로 할지 on 으로 할지.

관리하는 웹서버가 2 cpu 에 1 기가 메모리 입니다.
ㅣㅣ
평소에는 널널한데 몇달에 한번 몇시간 동안 수천 명 정도가 몰려서
엄청 느려집니다.
..
mysql 이나 php 소스등에서 나름대로 튜닝을 했고
아파치에서도 손을 좀 보려고 합니다.
..

아파치 웹서버의 설정에서
keepalive 를 on 으로 하는게 좋을까요
off 로 하는게 좋을까요..
..
폭주에 대한 노하우가 있으신 분들의 답변 부탁드립니다.
..

n10의 이미지

콘솔에서 x윈도우 설치...

레드렛 9.0 입니다..
처음설치할때 X윈도우로 설치를 하지 않았습니다..;
1번부터 4번까지 rpm 을 뒤졌는데요.. x윈도우 관련 rpm을 찾지못했습니다..ㅠㅠ
그놈으로 깔려고합니다..
고수님들 설치하는 방법 좀 가르켜주세요 ..(__)꾸벅..

pooh2451의 이미지

syslog에 대한 질문입니다.

커널의 message는 printk에서 KERN_DEBUG, KERN_INFO와 같은 priority로 log file에 저장되는 걸로 알고있는데..
user단에서의 process에서의 log massage는 꼭 syslog()를 이용해야 하는 건가요?

그리고 또 하나 궁금한 점은 logrotate를 이용하지 않고 syslogd만 돌아가고 있을 때 log file의 사이즈를 한정해주는 방법이 있는지 입니다. 만약 있다면 어디에서 어떻게 설정해야 하는지 궁급합니다.

만약 syslogd에서 log file 사이즈를 한정해 주는 설정이 없다면 default file size는 제공이 되는지, file full이 나면 그 다음에 들어오는 정보는 그대로 버려지는 것인지도 알려주시면 감사하겠습니다.

myth0312의 이미지

[q] 설치중 파일이 없는(?) 에러가 났다면...

Quote:

# rpm -Uvh AutoScan-0.95-R1.i586.Mandrake.rpm
경고: AutoScan-0.95-R1.i586.Mandrake.rpm: V3 DSA signature: NOKEY, key ID 005872ad
오류: Failed dependencies:
libcrypto.so.0.9.7 is needed by AutoScan-0.95-1.i586
libssl.so.0.9.7 is needed by AutoScan-0.95-1.i586

이런 에러가 나게되면 libcrypto.so.0.9.7,libssl.so.0.9.7 이둘의 파일을 구해서 어디에 카피 해주면 되는지요..

페이지

프로그래밍 QnA + 설치 및 활용 QnA 구독하기