MySQL 설치시 문제가 발생하네요.

익명 사용자의 이미지

안녕하세요 리눅스를 몇일전에 깔고 오늘 MySQL을 설치하는데 오류가 발생하네요. binary packages 다운받아서 전에 있던 APM(리눅스 설치시 전체 설치를 하여 APM이 모두 깔려있었습니다.)을 삭제하고 MySQL을 설치하는데 압축풀고, 디렉토리 옮기고 mysql_install_db 까지 입력한 후, safe_mysqld &를 하니 ended mysql이라는 문구가 뜨네요. 전까지는 매뉴얼의 결과 출력 화면과 같았는데요
./bin/safe_mysqld &를 입력하니 starting mysqld daemon with databased from /usr/local/mysql/data까지는 결과가 동일한데 그 뒤로 현재 시간과 ended mysql이라는 문구가 뜹니다. 뭐가 문제가 있는 걸까요..답변 주시면 감사하겠습니다.

익명 사용자의 이미지

설치된 mysql의 디렉도리와 파일의 ownership이 문제일 겁니다.
그걸 모두 mysql로 바꿔주시면 됩니다.

#chown -R mysql.mysql mysql