아파치 설치했는데 에러가...

server의 이미지

아파치를 실행한 결과.... 에러 메세지가 뜹니다.

# /etc/init.d/apache2 restart
* Apache2 has detected a syntax error in your configuration files:
Syntax error on line 6 of /usr/lib/apache2/conf/modules.d/70_mod_php5.conf:
Cannot load into server: libhistory.so.4:
cannot open shared object file: No such file or directory

이런 메세지가... 문제의 파일인 70_mod_php5.conf 파일에서 메세지에 나온 부분을

주석처리해서 아파치를 실행하면 정상적으로 실행이 됩니다.

테스트를 해보면 아파치는 정상적으로 돌아가는데 phpinfo 파일을 불러오면...

php 정보가 나오지않고 바로 파일 다운로드 창이 떠버립니다. 즉, php 가 아파치와

연동이 안된다는 것같은데요..

또 다른 문제의 파일인 libhistory.so.4 파일을 찾아보니깐.... 없습니다.;;;

다른 서버에 아파치2와 php를 연동해서 돌리는 서버에도 찾아봐도... 없습니다;;

뭐하는 파일인지... 당췌 알수가 없네요. 뭔가.... php 를 아파치와 연동하는데 필요한것

같기는한데... 파일은 보이질않고... 많은 조언 부탁드립니다.

참고로....

<IfDefine PHP5>

# Load the module first
<IfModule !sapi_apache2.c>
LoadModule php5_module modules/libphp5.so
</IfModule>

# Set it to handle the files
<IfModule mod_mime.c>
AddType application/x-httpd-php .php
AddType application/x-httpd-php .phtml
AddType application/x-httpd-php .php3
AddType application/x-httpd-php .php4
AddType application/x-httpd-php .php5
AddType application/x-httpd-php-source .phps
</IfModule>

</IfDefine>

문제의 /usr/lib/apache2/conf/modules.d/70_mod_php5.conf 파일의 설정부분입니다.

저기에 있는 LoadModule php5_module modules/libphp5.so 이 부분이 6번째 라인이고

수정을 가하지않은 상태입니다. 주석처리하면 아파치는 작동되지만 php와는 연동이 안되네요

분명 저 위치에 저 파일이 존재하는데도 말입니다. 구문 에러라고하는데 뭐가 잘못된것인지...;;