김정균의 블로그

김정균의 이미지

iPuTTY 0.70.2 release

putty 0.71 을 기다려 왔지만.. 나오지를 않네요. 아마도 0.61 출시 때 처럼 security issue 가 나오기 전에는 긴 release 잠복기를 가질 모양 입니다.

어쨌든, 0.71 이 나오지를 않아서 iPuTTY 는 0.70.2 로 release 를 합니다.

이번 릴리즈의 가장 주된 목적은 ZMODEM 전송 시에 drag & drop 으로 파일 전송이 가능해진 점입니다.

다음 목표로는 ligature font 지원을 생각하고 있는데, 이건 어떻게 해야할지 감도 안잡히네요 ㅠㅠ

https://github.com/iPuTTY/iPuTTY/releases/tag/l0.70.2i

김정균의 이미지

Let's encrypt 자동 발급 및 갱신

apache 2.4.33 에 mod_md 라는 모듈이 포함이 되었습니다. github 에서 Mozilla 의 후원으로 개발되는 ACME protocol 관리 모듈인데, Let's encrypt 인증서 자동 발급/갱신이 가능 합니다.

이 모듈을 이용하면 아예 발급/갱신 과정이 생략되다시피 합니다.

https://my.oops.org/188 에 간단하게 설명을 해 놓았으니 혹시 apache 로 let's encrypt 를 이용하시는 분들은 사용 고려를 한번 해 보시기 바랍니다.

김정균의 이미지

Let's encrypt wildcard 인증서 출시

2/27 출시 한다고 했다가 연기 되었는데, 현지 시간 3/13 에 드디어 출시가 되었습니다. 어제 certbot 이 업데이트 되었길래 출시 준비 중인가 했는데, 출시가 되어서 업데이트가 되었던 모양이네요.

KLDP 인증서 교체한지 며칠 안되었는데, 조금 확인해 보고 갈아타야 겠습니다. 참고로 다음과 같이 업데이트 하시면 됩니다.

김정균의 이미지

CentOS 7.4 new spectre 패치

3월 5일경에 CentOS 7.4 의 새로운 커널이 출시 되었습니다.

새로 출시된 3.10.0-693.21.1.el7.x86_64 커널의 특징은 google의 spectre retpoline 패치를 반영했다는 것입니다.

처음 meltdown, spectre 버그가 발표 되었을 당시에만 해도, spectre 패치의 성능 저하는 거의 없고, meltdown 의 패치로 인한 성능 저하가 엄청나다라고 알려졌었습니다.

하지만, 실제 테스트 결과로는 spectre 버그의 ibrs 패치가 엄청난 성능 저하를 발생 시키는 것으로 다시 알려 졌습니다.

3.10.0-693.21.1.el7.x86_64 커널에 포함된 retpoline 패치는 제 빌드 서버에서의 테스트로는 손실을 거의 경감 시켜주는 듯 싶습니다.

김정균의 이미지

CentOS 7.4 & AnNyung 3.2

2017.08.01 RHEL 7.4 출시
2017.08.24 CentOS 7.4.1708 CR 출시

CentOS 7.4.1708 버전이 9월 첫째주 또는 둘째주에 출실될 예정입니다. 현재 7.4에 업데이트될 package들을 CR(Continuous Release) repository로 선공개가 되었습니다.

http://mirror.centos.org/centos/7/cr/x86_64/Packages/

일단, CentOS 7.4에서의 가장 큰 변화는, HTTP/2 를 지원하기 위한 openssl 의ALPN 기능이 포함된 openssl 1.0.2k로 업데이트 되었다는 점입니다. (물론 제 입장에서 입니다. ^^)

안녕에서는 ALPN기능을 back porting 하여 지원하고 있었는데, CentOS에서 지원을 하니, 패키징 한개 덜 할 수 있다는 반가움이 있습니다. ^^;

김정균의 이미지

iPuTTY 0.70 release

putty 0.70 릴리즈를 반영한 iPuTTY 0.70 이 release 되었습니다.

iPuTTY 업데이트 사항:

김정균의 이미지

iPuTTY 0.69.1 release

https://kldp.org/node/157747 에서 언급한 기능 추가를 위하여, putty 0.70 릴리즈전이라 0.69.1로 릴리즈를 합니다.

  • ZMODEM 기능 지원
    1. iPuTTY console을 이용하여 파일 업로드/다운로드를 지원 합니다.
  • 세션별 암호 저장 기능 지원
  • pagent icon을 PuTTYTray icon으로 변경
  • 자세한 사항은 아래의 Release page를 참고 하십시오.

릴리즈 패키지는 https://github.com/iPuTTY/iPuTTY/releases/tag/l0.69.1i 에서 제공 합니다.

김정균의 이미지

iPuTTY ZMODEM 지원

LePuTTY의 ZMODEM 기능을 iPuTTY에 포팅을 했습니다.

일단, 동작은 잘 하는 것 같네요. 좀 더 사용해 보고 문제가 없으면 0.69.1 로 릴리즈 할 예정 입니다. 그전에 PuTTY 0.70이 나오면 0.70으로 릴리즈 될 것이고요 :-)

https://github.com/iPuTTY/iPuTTY/pull/25

참고 하세요.

빌드가 가능 하신 분들은 master branch나 localization branch를 받아서 빌드하시면 사용 가능 합니다. 빌드 방법은 https://github.com/iPuTTY/iPuTTY/wiki/Build 참조 하세요.

김정균의 이미지

iPuTTY 0.69 release

따끈한 iPuTTY 업데이트 소식입니다.

4/29 자로 PuTTY 0.69 보안버그 버전이 나왔고, 이를 반영한 iPuTTY 0.69가 릴리즈 되었습니다.

프로젝트는 중단이 되었고, 저는 계속 사용해야 하다보니, 일단 GUI 프로그램 개발 경험이 전무한 제가 맡아서 하게 되었습니다.

마지막 버전 0.63을 PuTTY 0.69에 반영을 하였고, 몇가지 기능들을 추가하여 0.69를 릴리즈 했습니다.

김정균의 이미지

브라우저 주소창 "안전하지 않음"의 의미

며칠 전 Firefox와 Chrome이 각각 51, 56으로 업데이트 되었습니다.

이 업데이트판은 중요한 변화를 가지고 있습니다. 일단 KLDP 입장에서는 이 두 버전이 StartSSL을 ban 하여 인증서 공황 상태에 빠트렸습니다. 제게 개삽질을 시킨 것이죠.

두번째로, 확실한 사항은 아닌데, http protocol로 특정 페이지에 접근을 했을 때에, form 문에 password 속성을 가진 input이 있을 경우 주소창에 "안전하지 않음"을 나타냅니다. 구글의 경우에는 text로 보여주며, Fireforx의 경우에는 불안전한 ssl 접근 표시인 자물쇠가 표시 됩니다. (지금 보니 naver daum 모두 그러네요.)

이게 취지는 알겠는데, 문제는 기술적으로 문제가 있는 것 처럼 보이는게 문제네요. 그냥 확 SSL로 바꾸면 될 것 같지만 실제로 이게 쉽지 않다는게 함정인데..

페이지

RSS - 김정균의 블로그 구독하기